Member Login

You are not currently logged in.






» Register
» Lost your Password?

Thesis 2.0 custom templates | General Thesis Questions | Forum

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Save $200 on Membership Now!

Start learning today for as little as
$0.82 PER DAY!
THIS IS A LIMITED TIME OFFER!


 
You must be logged in to post


Lost Your Password?

Search Forums:


 






Minimum search word length is 4 characters – Maximum search word length is 84 characters
Wildcard Usage:
*  matches any number of characters    %  matches exactly one character

Thesis 2.0 custom templates

UserPost

6:58 am
October 4, 2012


Alexandre Roussak

Member

posts 13

1

Hi everybody!

Thesis 2.0 has skin editor with several templates and possibility to add custom templates.

Well, when i am working with the page from Wordpress admin panel I can see the switcher between templates and custom templates there. But when i choose some of them and updating the page, nothing happens.

Can anybody explain me how to add custom template for any particular page in thesis 2.0?

Thanks in advance!

7:29 am
October 4, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

2

Well, you can't use a custom template on the Front Page – it already has its own template, and you can't on the Posts Page – for the same reason.  Otherwise it should work exactly as you are expecting it to.

8:13 am
October 4, 2012


Alexandre Roussak

Member

posts 13

3

Post edited 8:16 am – October 4, 2012 by Alexandre Roussak


Thanks Rick.

But what is the use of Landing Page template?

And actually I was trying to add custom template to any page and it didn't work with any of them.

8:37 am
October 4, 2012


Brian Tozer

Founding Member

posts 1000

4

Rick Anderson said:

Well, you can't use a custom template on the Front Page – it already has its own template, and you can't on the Posts Page – for the same reason.  Otherwise it should work exactly as you are expecting it to.

 

Now I am confused.

I thought that we could use any template anywhere.

To customise any page uniquely.

Are there limitations that we need to be aware of?

8:58 am
October 4, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

5

The Front Page template can ONLY apply to the static front page the Blog template can ONLY apply to the posts page.  No other template can be used on either of those pages.  Which is why they exist.

9:17 am
October 4, 2012


Alexandre Roussak

Member

posts 13

6

Post edited 9:17 am – October 4, 2012 by Alexandre Roussak


OK, but which custom templates can be applied and to which pages?

2:41 pm
October 4, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

7

The only pages that can't take a custom template are the Front Page and the Posts Page.  Otherwise every other post, page, custom post type, category, tag, archive, custom taxonomy page can be assigned a custom template.

You could make every single page on your site use a different template.

11:04 am
October 5, 2012


Jeff Robb

Member

posts 13

8

I have found that using the custom templates there is some issues:

1) from the front page, I designed my layout
2) I created a custom template from the option
3) from the custom template I created I copied over the front page layout so I could make a few adjustments
4) once I made changes within the new custom template I called 2 Columns I found that all changes I was making also affected my front page. I changed for example the header class to header2 so that I could style it differently and somehow the front page template also changed it's name to header2 causing issues. Every change I made to the containers also changed on the front page template. Is this because I copied the template? Will it also cause issues if I just remake it from scratch? Seems like a lot of work per website if I cannot copy a template and make a few stylistic changes by changing the class and the css to go with the class.

2:21 pm
October 5, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

9

Jeff, it's not supposed to work like that.  I'm going to practice some of that myself over the weekend to see how it works for me.  Changing a custom template shouldn't have any affect on the template that was used to create it.

4:38 pm
October 5, 2012


Jeff Robb

Member

posts 13

10

Let me know how it goes. I also noticed that the favicon filter doesn't work. I put the favicon in my header script to get it to work.

7:04 am
October 6, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

11

It worked fine for me.  Here is a page with a custom template applied to it.  It did not have any affect on the template that I copied.  I also had an issue with the favicon uploader and have notified the dev team.

11:34 pm
October 8, 2012


Alexandre Roussak

Member

posts 13

12

Rick, I believe i am not the one who has this issue. Let's say we add some page on our site. This is not a front page, this is not posts page. This is just some other page – let's say page "about us" . After trying to assign custom skin template (for example "landing page" or some custom template we could create ) nothing happens. The page still has template "page" .

I am really frustrated – what to do to use custom template on different page?

Thanks, in advance.

5:40 am
October 9, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

13

Alexandre, can you post a link to a page with no custom template and a page that should be using a custom template?  I'd like to see the HTML that you see.

6:01 am
October 9, 2012


Alexandre Roussak

Member

posts 13

14

I am experimenting on local host. What part of HTML is important for this issue?

Also, I found out kinda strange thing : If i install custom post type UI pluggin and create several custom posts – they perfectly work with custom template switcher.

What is also interesting after that happened i started to be able to switch templates of my site pages. Even after deleting custom posts and deactivating custom post type plugin – I am able to switch custom templates on regular pages of my site.

6:07 am
October 9, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

15

The chances are that the problem with custom templates that you are having is due to working locally.  There have been a number of reports of issues when running on some version of WAMP, MAMP, etc.  

I found this to be the case during alpha testing and thus switched to working on a development subdomain.  When I did that my odd issues disappeared.

At the moment the dev team is working on issues related to this and I expect that the next version (due out any day/hour now) will go a long way to resolving this.

6:12 am
October 9, 2012


Alexandre Roussak

Member

posts 13

16

Well, what I found – this is not the metter of using custom post type plugin! As soon as I changed permalink structure to any one from default – custom templates started to work !!!!!

10:21 am
October 9, 2012


Rick Anderson

Edmonds, WA

Admin

posts 10159

17

Excellent – I don't know why the permalink settings matter but I'm glad it's working.



About the Build Your Own Business Website Forum

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online: Keith W Jones
20 Guests

Currently Browsing this Topic:
1 Guest

Forum Stats:

Groups: 8
Forums: 45
Topics: 5033
Posts: 23670

Membership:

There are 5230 Members
There have been 3 Guests

There are 2 Admins
There are 4 Moderators

Top Posters:

Brian Tozer – 1000
Carolin – 475
Reece Morrel – 350
Keith W Jones – 323
John Cunningham – 259
Heidi Hafner – 247

Recent New Members: Joanna Bostwick, Nathan Capps, Adolfo Calsin Juli, danae seguineau, John Pugh, Brian Weber

Administrators: Rick Anderson (10159 Posts), Rick Anderson (0 Posts)

Moderators: Gelie Laxamana (15 Posts), Laura Nugent (1 Post), Jorene (0 Posts), Robert Begun (0 Posts)