Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Thesis 2.1 - Error Message related to BYOB Featured Image Box After Server Uppgraded to PHP 5.4
Avatar
Carolin
Arizona
Member
Members

Community Member
Forum Posts: 983
Member Since:
February 14, 2012
sp_UserOfflineSmall Offline
1
April 30, 2014 - 1:05 pm
sp_Permalink sp_Print sp_EditHistory

Rick

 

On the Hostgater sandbox hosting space I am using they upgraded the PHP today to PHP 5.4.

Since that happened I am seeing this error message on the admin panel of one of the sites on the space.

The error message did not exist until the PHP 5.4 update occurred -- but I am questioning that the PHP is even the culprit.

Warning: Creating default object from empty value in /home3/ben24016/public_html/goldcnew/wp-content/thesis/boxes/byob_featured_image1/box.php on line 22

I actually don't see anything that is visually wrong with the front end of the site where this message is showing up on the Admin panel — but maybe I just haven't discovered what the visual issue might be yet.

The site where this is happening is an old Thesis 2.0 site I cloned on the space to redo and upgrade to Thesis 2.1.

I checked and the BYOB Featured Image Box is version 1.0.2 and there is not a nag that there is a new version to be upgraded.

 

Now here is the stranger thing --- I went and checked the original site of this clone -- which is also on a different Hostgater space. Hostgater upgraded the PHP to PHP 5.4 on that server space about a week ago. There is no similar error message on that site with the PHP 5.4 installed. I would have thought if this issue is actually related to the PHP 5.4 upgrade that it would be showing up there as well.This older site is still on WP 3.5.2 and Thesis 2.0 and the BYOB Featured Image Box is 1.0.2.

 

Any idea what I might need to do to correct this problem/error message?

 

Thanks much.

Carolin Benjamin WordPress Design & Consulting

Provide ‘white label’ support to web and advertising agencies that need extra help from time to time -
Also consulting, design & web construction for businesses, non-profits & sole-practitioners

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
2
April 30, 2014 - 3:16 pm
sp_Permalink sp_Print

The problem is that the BYOB Featured Image Box has been renamed and installed with the wrong name.  Note that in the error message the folder is named byob_featured_image1.  Simply rename that folder using Filezilla to remove the number 1 from the name and it will all work just fine.

Avatar
Carolin
Arizona
Member
Members

Community Member
Forum Posts: 983
Member Since:
February 14, 2012
sp_UserOfflineSmall Offline
3
April 30, 2014 - 3:19 pm
sp_Permalink sp_Print sp_EditHistory

Ok — I can do that — strange how the error only showed up when the PHP was upgraded.

Thanks much.

 

(Update -- that did the trick -- things are good.)

Carolin Benjamin WordPress Design & Consulting

Provide ‘white label’ support to web and advertising agencies that need extra help from time to time -
Also consulting, design & web construction for businesses, non-profits & sole-practitioners

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
4
April 30, 2014 - 3:34 pm
sp_Permalink sp_Print

New PHP means new error messages

Avatar
Deborah Savadra
Central Gulf Coast, AL, USA
Jedi
Members

Community Member
Forum Posts: 91
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
5
May 4, 2014 - 12:53 pm
sp_Permalink sp_Print sp_EditHistory

Tried that, but it not only got rid of the error, it also got rid of the featured images, too. Tried deleting the box and re-installing – the same error re-appeared, even though the folder is now correctly named. The images themselves, thankfully, seem to be displaying okay, but my client's a little annoyed by the error message.

Avatar
Deborah Savadra
Central Gulf Coast, AL, USA
Jedi
Members

Community Member
Forum Posts: 91
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
6
May 7, 2014 - 4:50 am
sp_Permalink sp_Print

Still getting this error ...

Image Enlarger

 

... and when I uploaded that to the Media Library, I got this additional error:

 

Image Enlarger

Site is http://reclaimyourtrueemotions.com; it's on WordPress 3.9 / Thesis 2.18 / PHP 5.4.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
7
May 7, 2014 - 7:10 am
sp_Permalink sp_Print

I'm guessing that there is some sort of plugin conflict.  The error message means that WordPress isn't returning the list of registered image sizes.  There were some big changes to the media library in 3.9 but this box seems to be working elsewhere just fine and the function for identifying those image sizes hasn't changed.

However, you can always simply disable the box and use the built in Featured Image box that now comes with Thesis instead.

Avatar
Deborah Savadra
Central Gulf Coast, AL, USA
Jedi
Members

Community Member
Forum Posts: 91
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
8
May 7, 2014 - 11:38 am
sp_Permalink sp_Print

I'm just going to uninstall the BYOB box, then. It's now interfering with creating new posts. I'll have to take a look at whatever the new Featured Image functionality is in Thesis -- I could not find it in the previous version. Thanks for the heads-up on that one.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
9
May 7, 2014 - 12:35 pm
sp_Permalink sp_Print

Keep an eye out for other plugin issues.  The problem isn't native to the box itself - at least it is working fine on all my sites, so if it appears to be an issue in the post editor as well then there is probably a larger problem.

You might look for plugins that interact with the images on the site.

Avatar
Deborah Savadra
Central Gulf Coast, AL, USA
Jedi
Members

Community Member
Forum Posts: 91
Member Since:
December 25, 2010
sp_UserOfflineSmall Offline
10
May 7, 2014 - 12:58 pm
sp_Permalink sp_Print

What is the "featured image" box/container/whatever called in Thesis 2.18? I don't see it in the skin editor under either WP Featured Image or Featured Image.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
11
May 7, 2014 - 2:40 pm
sp_Permalink sp_Print

It is contained inside of the Post Box.  It is one of the elements of the post box.

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
19 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1434

Brian Tozer: 1004

Carolin: 983

Heidi Hafner: 509

John Cunningham: 423

Reece Morrel: 353

Newest Members:

digitalaerolus

emma62755

sharonmarks

emma80233

Tijs de Jong

Daniel Frey

Forum Stats:

Groups: 8

Forums: 46

Topics: 6999

Posts: 34817

 

Member Stats:

Guest Posters: 6

Members: 6762

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent