Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Need help with site header CSS please
Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 141
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
1
September 5, 2019 - 1:46 pm
sp_Permalink sp_Print

The website is https://www.ruach.org. About a year ago, Rick helped me write custom CSS to have the header text colors match the footer, and to change the color of the social media icons:

 

/*To change the text and link color of the contact top header area to match footer*/
#top_header_area .widget p, widget {
color: #dcdcdc;
font-size: 18px;
}
#top_header_area .widget p, .widget a{
color: #e3c8fe;
}
#top_header_area .widget p, .widget a:hover{
color: #ffffff;
}
/*To change social media icon color in top header area to match footer*/
#top_header_area i.fa {
color: #e3c8fe;
margin-bottom: 10px;
font-size: 25px;
}
#top_header_area i.fa:hover{
color: #fff;
margin-bottom: 10px;
font-size: 25px;
}

 

Now, this css is not working and I can't figure out why. I can make the changes in the Inspector, but can't figure out what to do with the custom CSS. I have not made any other changes other than content. Of course, there have been lots of WordPress and plugin updates, and I am using Gutenberg, although the header is just WordPress widgets.

 

We are entering the busiest time of year, so the timing of this is pretty bad (not that timing is ever good for a site to break)! Any help would be appreciated.

 

Thanks,

Marcy

Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 141
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
2
September 9, 2019 - 12:14 pm
sp_Permalink sp_Print

I was able to fix the header widget color. It turned out it was being overridden by the Main Side Widget color. I've never even used the Main Side Widget, but when I changed those colors, I got the Header Widget text and links colors to change.

Still stuck on the social icons, which Rick helped me with CSS a while ago. And with the margin on the bottom of the Header. It is way too much, and I have CSS for that too that is not working.

Any help would still be appreciated.

Thanks,
Marcy

Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 141
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
3
September 10, 2019 - 10:51 am
sp_Permalink sp_Print

OK - I broke something!! I got this in the GoDaddy error log yesterday:

[09-Sep-2019 18:59:33 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function request_filesystem_credentials() in /home/shekhinah18/public_html/wp-content/thesis/skins/byob_agility_nude/includes/design/byob_generate_editor_css.php:55
Stack trace:
#0 /home/shekhinah18/public_html/wp-content/thesis/skins/byob_agility_nude/skin.php(1314): byob_generate_editor_css->write_file()
#1 /home/shekhinah18/public_html/wp-includes/class-wp-hook.php(288): byob_agility_nude->filter_css('/*---:[ Thesis ...')
#2 /home/shekhinah18/public_html/wp-includes/plugin.php(208): WP_Hook->apply_filters('/*---:[ Thesis ...', Array)
#3 /home/shekhinah18/public_html/wp-content/themes/thesis/lib/core/skin/css.php(248): apply_filters('thesis_css', '/*---:[ Thesis ...', '/*---:[ Thesis ...', '/**************...')
#4 /home/shekhinah18/public_html/wp-content/themes/thesis/lib/core/skin/css.php(173): thesis_css->update('/**************...', '', false, true)
#5 /home/shekhinah18/public_html/wp-includes/class-wp-hook.php(286): thesis_css->canvas_head('')
#6 /home/shekhinah18/publi in /home/shekhinah18/public_html/wp-content/thesis/skins/byob_agility_nude/includes/design/byob_generate_editor_css.php on line 55

Anyone have any idea what I did and how to fix it? I looked at CSS in the Skin Editor, but did not change anything. I was trying to fix the custom CSS. 

The CSS for the top header left column text looks like this:

CSS.JPGImage Enlarger
But when I right click and copy the CSS path, I get this: div#top_header_columns.columns_4112 div.one-quarter div#text-15.#top_header_area..widget.widget.widget_text I don't know what the 2 dots are, where they came from, and why widget is in there three times. I still have no clue why the social media icons in the top header won't take the custom css colors. Thanks,

Marcy

sp_PlupAttachments Attachments
Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 141
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
4
September 10, 2019 - 11:01 am
sp_Permalink sp_Print

OK, somehow I fixed most of the issues, I'm not sure what I did.

 

If anyone can help me dechipher the error messages, that would help a lot.

 

Thanks,
Marcy

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
24 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1428

Brian Tozer: 1004

Carolin: 982

Heidi Hafner: 508

John Cunningham: 423

Reece Morrel: 353

Newest Members:

emma62755

sharonmarks

emma80233

Tijs de Jong

Daniel Frey

mutek

Forum Stats:

Groups: 8

Forums: 46

Topics: 6995

Posts: 34796

 

Member Stats:

Guest Posters: 6

Members: 6761

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent