Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Forum Responsiveness?
Avatar
John Wade
Jedi
Community Member

Members
Forum Posts: 110
Member Since:
January 12, 2013
sp_UserOfflineSmall Offline
1
January 1, 2019 - 9:02 am
sp_Permalink sp_Print

I'm wondering if I am doing something wrong with regards to posting questions. I have posted several questions that don't seem to generate the responsiveness that I once enjoyed. There are several outstanding for almost a month (or about that). I've sent Rick 2 personal emails to learn if I'm doing something incorrect protocol-wise and left one phone message. Again, no replies. I thought maybe time of year but considering the time line now and frequency of inquiry I would have expected that I would have heard something back, even if it was just a, "Hey, it's the holiday season, give us a break, things will be back to normal level of expected service by . . ." But, radio silence across the board. I thought maybe something of a personal nature as well may be impacting Rick and if so, I'd just like to know one way or another as I'd like to make some progress on my site as planned or put things on hold accordingly if there are unforeseen circumstances impacting my membership. For what it's worth, I purchased a life time memberships some time back.

John

John Wade

Avatar
Pierre Cote
Moderator
Members

Moderators

Community Member
Forum Posts: 1138
Member Since:
September 21, 2014
sp_UserOnlineSmall Online
2
January 5, 2019 - 1:24 am
sp_Permalink sp_Print

Hi John

I'm wondering if I am doing something wrong with regards to posting questions.

Not per see, but software are changing fast these days, so be patient.

Pierre ( postrophe )

Avatar
John Wade
Jedi
Community Member

Members
Forum Posts: 110
Member Since:
January 12, 2013
sp_UserOfflineSmall Offline
3
January 5, 2019 - 7:46 am
sp_Permalink sp_Print

Patient? I feel that at this point without elaboration as to why I should further my patience, that is an unfair request. As mentioned, after investing $850 for a lifetime membership, I've posted questions closing on a month old, personal emails to Rick, a phone call to Rick, several forum appeals to Rick; without a response. With all due respect, I believe I have been the model of patience and for that matter, respect.

John Wade

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online: Pierre Cote, Jennifer
19 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1389

Brian Tozer: 1004

Carolin: 979

Heidi Hafner: 470

John Cunningham: 422

Reece Morrel: 353

Newest Members:

shibi s

emma72784

Chris Hall

Alex Borissov

Valverdi_5 na

middleageguysclub

Forum Stats:

Groups: 8

Forums: 46

Topics: 6958

Posts: 34607

 

Member Stats:

Guest Posters: 6

Members: 6749

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent