Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Using S3flowshield with Amazon Cloudfront
Avatar
Azmat
Member
Members
Forum Posts: 41
Member Since:
November 9, 2011
sp_UserOfflineSmall Offline
1
February 24, 2013 - 9:39 am
sp_Permalink sp_Print

I've installed S3flowshield plugin to protect the location of my audio content in amazon s3 buckets.  The audios do work but I've noticed a lag in time to play the audios. For some reason, the lag is especially longer on mobile devices (iphone5) vs desktop (sometimes as long 10 seconds to play 2mb audio-3minutes).

I was thinking about using Amazon Cloudfront to speed up the time to deliver the audios  to visitors.  

However, it does not seem like S3flowshield supports amazon cloudfront. 

I think the videos for BYOB are hosted on amazon and use the s3flowshield plugin.  Does BYOB use cloudfront to deliver audio content? If so could you explain how you linked up s3flowshield with cloudfront to play the content?  Maybe there is some configuration I messed up.  Appreciate the help.  Thanks!

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
2
February 24, 2013 - 2:59 pm
sp_Permalink sp_Print

Have you compared this to how long it takes to load the same audio hosted on your site?  It would be a good control test.

You can't use Cloudfront with S3Flowshield.

However, unless you are viewing the site on a mobile device any of the lessons here are delivered via S3Flowshield and AmazonS3.

What are the chances that the player is waiting to begin playing until the entire audio is downloaded?

Avatar
Azmat
Member
Members
Forum Posts: 41
Member Since:
November 9, 2011
sp_UserOfflineSmall Offline
3
February 28, 2013 - 7:18 am
sp_Permalink sp_Print

Thanks Rick.  I tried out your suggestions and I think the issue might be with the S3flowshield shortcode.  Here is what I found

1) If I use just the amazon s3 bucket url for the player the audios are played fast both on desktop and mobile devices.

2) If I use the s3flowshield shortcode [S3URL file='PATH_TO_FILE'] then audio takes a little while on desktop but a really long time on the iphone (sometimes as long as 20 seconds).

 

My guess is that for some reason the shortcode is taking long to generate the url path to the file and that's why there is such a long delay.

 

Do you have any suggestions on ideas on how to fix this issue?  Appreciate the help.  Thanks!

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
4
February 28, 2013 - 8:03 am
sp_Permalink sp_Print

I don't know of a way to speed up FlowShield, however, I also haven't observed this behavior with videos.  It could be that the delay is in the interface with the player.  From what you describe it feels to me like it doesn't start playing until some amount of the file has been downloaded.  (Perhaps all of the file).

Maybe the player has a setting that you can adjust?  Look for a buffer setting in the code, or a buffer variable.   Maybe this is a limitation of HTML 5 audio?

Avatar
Azmat
Member
Members
Forum Posts: 41
Member Since:
November 9, 2011
sp_UserOfflineSmall Offline
5
February 28, 2013 - 8:06 am
sp_Permalink sp_Print

Thanks Rick.  I don't know if the issue is with the player though.  Because when I remove the s3flowshield shortcode the audios load up fast.  It's only after I use the shortcode that I see delays.  So that's why I was thinking the problem might be with using shortcodes.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
6
February 28, 2013 - 8:12 am
sp_Permalink sp_Print

Perhaps the raw encryption slows it down.

You could put in a support ticket with them.  I've found them to be helpful in the past.

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1428

Brian Tozer: 1004

Carolin: 982

Heidi Hafner: 508

John Cunningham: 423

Reece Morrel: 353

Newest Members:

emma62755

sharonmarks

emma80233

Tijs de Jong

Daniel Frey

mutek

Forum Stats:

Groups: 8

Forums: 46

Topics: 6993

Posts: 34790

 

Member Stats:

Guest Posters: 6

Members: 6761

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent