Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Skin.php errors
Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 153
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
21
October 3, 2018 - 2:16 pm
sp_Permalink sp_Print

Keith,

Yes, when it was changed to PHP version 5.6, it worked. I'm leaving it alone now!

Thanks for your help, and with my other posts as well,
Marcy

Avatar
Carolin
Arizona
Member
Members

Community Member
Forum Posts: 984
Member Since:
February 14, 2012
sp_UserOfflineSmall Offline
22
October 3, 2018 - 5:17 pm
sp_Permalink sp_Print

Marcy --

Glad it finally got resolved for you and that the website is working.

I hear you about leaving a project be, once you get a problem site working again after struggling for a long time --  (been there, done that).

At some point you'll have to deal with upgrading the older PHP 5.6  ------ but maybe not today 🙂

Carolin Benjamin WordPress Design & Consulting

Provide ‘white label’ support to web and advertising agencies that need extra help from time to time -
Also consulting, design & web construction for businesses, non-profits & sole-practitioners

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
23
October 4, 2018 - 10:41 am
sp_Permalink sp_Print

In fact, you should really look at upgrading to PHP 7.2 if you can.  It won't be very long before WordPress doesn't support 5.6 and newer versions of popular plugins are removing compatibility for 5.6

Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 153
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
24
October 4, 2018 - 1:04 pm
sp_Permalink sp_Print

I really, really did not want to use 5.6, but the migration did not work otherwise. All my other sites are at 7.1. And I heard today that WordPress 5.0 may release on November 19.

Since I migrated this site into a folder that originally had a Dreamweaver site in it, I'm thinking of really starting clean - renaming the current working folder, creating a new folder and database, and then migrating again to see if that would work.

I assume Agility is fine with 7.2 or you would not be recommending it.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
25
October 4, 2018 - 3:01 pm
sp_Permalink sp_Print

No, I think there is a glitch with Thesis at 7.2.  There may also be a glitch with Agility.  The next update of Agility will be compatible with 7.2 

Avatar
Marcy
Jedi
Members

Community Member
Forum Posts: 153
Member Since:
July 25, 2017
sp_UserOfflineSmall Offline
26
October 9, 2018 - 8:48 am
sp_Permalink sp_Print

Rick,

I looked up PHP 5.6 support and it will be gone by the end of this year. Also, with WordPress 5.0 being released in November, I'm assuming this may affect the PHP version also.

What might be a reason a site would work with php 5.6 and not with php 7.0 or 7.1? The dev site worked with 7.1, the migrated site won't. I'm still trying to get help from iThemes, which lately has become harder to do. I've tried most of what Keith and Carolin suggested, with no real luck.

Thanks,
Marcy

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
27
November 4, 2018 - 8:17 am
sp_Permalink sp_Print

The reason software that works in PHP 5.6 doesn't work in 7.0 is that many practices that were acceptable in 5.6 have proven to have vulnerabilities that 7.0 has closed off.  There really are lots non backward compatible differences between 7.0 & 5.6

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1441

Brian Tozer: 1004

Carolin: 984

Heidi Hafner: 509

John Cunningham: 423

Reece Morrel: 353

Newest Members:

soundpilot

digitalaerolus

emma62755

sharonmarks

emma80233

Tijs de Jong

Forum Stats:

Groups: 8

Forums: 46

Topics: 7003

Posts: 34845

 

Member Stats:

Guest Posters: 6

Members: 6763

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent