Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Marketpress and Thesis 2.1 design not working
Avatar
Giles Wilson
Member
Members
Forum Posts: 13
Member Since:
July 17, 2013
sp_UserOfflineSmall Offline
1
January 15, 2014 - 2:34 pm
sp_Permalink sp_Print

Hi again Rick

 

I'm building my Market press shop on my Thesis site, and have used some of your boxes to help make it smarter. But I'm having trouble editing the design of the site, even basic things like colors and fonts and even layout. I expected the normal Thesis design options to control this, but it doesn't seem to, and nothing I change there has any effect on how the site actually looks. Have I missed a crucial step?

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13616
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
2
January 15, 2014 - 2:44 pm
sp_Permalink sp_Print

Giles, I'm in the process of revamping my boxes for MarketPress to add a bunch more design control via the Thesis interface. I've just emailed you two of them to try.

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13616
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
3
January 15, 2014 - 2:45 pm
sp_Permalink sp_Print

I should add that all design settings can be found under the Boxes menu at Thesis Home.

Avatar
Giles Wilson
Member
Members
Forum Posts: 13
Member Since:
July 17, 2013
sp_UserOfflineSmall Offline
4
January 15, 2014 - 2:49 pm
sp_Permalink sp_Print

Thanks Rick, I'll try them out. 

Avatar
Giles Wilson
Member
Members
Forum Posts: 13
Member Since:
July 17, 2013
sp_UserOfflineSmall Offline
5
January 21, 2014 - 2:03 pm
sp_Permalink sp_Print

Thanks for those boxes Rick. I think my problem is a bit more fundamental though. I can't get any change at all in the Thesis design to register on my multisite MarketPress shop. The shop seems to be finding a styling from somewhere which is overriding what I am telling it to do via Thesis. I'm not sure where to begin in discovering where the rogue style is coming from or why it's there. 

 

Does anything spring to mind?

 

Thanks as ever

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13616
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
6
January 22, 2014 - 6:04 am
sp_Permalink sp_Print

Giles, do you have Thesis properly configured to work with Multisite?  It takes a little extra work to set it up in the Network version of WordPress.

Avatar
Giles Wilson
Member
Members
Forum Posts: 13
Member Since:
July 17, 2013
sp_UserOfflineSmall Offline
7
January 22, 2014 - 2:41 pm
sp_Permalink sp_Print

Doh! Thanks Rick - a case of me not having RTFM properly.

 

So I've done that - adapting the .htaccess file as it suggests and uploading it, and hey presto the shop site is taking the correct design - which is brilliant.

 

BUT it's created another problem. I am now unable to login to the shop's dashboard because of a "redirect loop". Getting into the network admin dashboard is fine, but not the individual shops. 

 

So here are some links:

The dashboard for market.wansteadium.com works fine (that's the network admin dashboard)

But the dashboard for market.wansteadium.com/thewansteadtap is now unavailable.

I'm guessing I need to put in another line of code into the .htaccess file...?

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13616
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
8
January 23, 2014 - 6:53 am
sp_Permalink sp_Print

I believe that WPMUDev has an article on setting up MarketPress in a network environment.  I would look there for how to set that up.

This is something I want to be able to do, but I've never had the chance to play with it before so...

Avatar
Giles Wilson
Member
Members
Forum Posts: 13
Member Since:
July 17, 2013
sp_UserOfflineSmall Offline
9
January 24, 2014 - 3:46 pm
sp_Permalink sp_Print

I've got it working fine now - thanks to the DIYThemes article you mentioned and help from WPMU. 

http://premium.wpmudev.org/for.....ost-594127

You're right, it is a bit tricky to set up but now seems to be fine. 

smile

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13616
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
10
January 24, 2014 - 3:47 pm
sp_Permalink sp_Print

Excellent!

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
3 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1371

Brian Tozer: 1004

Carolin: 979

Heidi Hafner: 470

John Cunningham: 422

Reece Morrel: 353

Newest Members:

David

Dina Jokanovic

kwitchey

Kirk Ewing

Md Saifullah

Ian Birch

Forum Stats:

Groups: 8

Forums: 46

Topics: 6949

Posts: 34546

 

Member Stats:

Guest Posters: 6

Members: 6743

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent