Build Your Own Business Website header image

Welcome to our Members Only Forum

You are welcome to view the content on our Forum, just scroll down to view this forum post.
If you like what you find and want to be able to post a question, please check out our subscription options.
Please feel free to search the forum using either the Google Site Search above or the forum search below.

Avatar
Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed sp_TopicIcon
Agility navbar went funky
Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
1
May 31, 2019 - 5:20 pm
sp_Permalink sp_Print

Hi y'all...

My client has a "friend" who has been doing edits on her website for her. Now we seem to have a glitch with the navbar and I can't figure out why this is happening. I use Chrome and my client is using Firefox. The navbar shows up a normal size at first and when you refresh it doubles its height. The "friend" added a new slideshow and video and moved the navbar above the slider and video. It looks as if she moved it in the template for all pages... but my little tool isn't showing me why this extra height is showing up. Sometimes the height just randomly clicks back to normal size without doing anything. It's so weird. 

Any help would be appreciated.

Thanks,

Heidi Hafner,
Hafner Designs

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
2
June 3, 2019 - 10:48 am
sp_Permalink sp_Print

Heidi - my guess is the "friend" has a business called "GREAT GIGS".  You'll find that they wrote a bunch of custom CSS using the WordPress builtin CSS editor.

This code conflicts with other code on the site - which causes that problem.  I'd start by deleting all of the GREAT GIGS code and then use the Thesis and Agility system for adjusting what needs to be adjusted.

The negative margins are likely causing part of the problem.

Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
3
June 3, 2019 - 5:16 pm
sp_Permalink sp_Print

Thank you, Rick. I have told my client that the extra CSS coding that she's used is messing up the theme. I will reiterate with her. 

Heidi Hafner,
Hafner Designs

Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
4
June 3, 2019 - 5:54 pm
sp_Permalink sp_Print

Do the CSS edits made in the WP editor take priority over the theme CSS? My client wants me to leave it all alone except for the navbar glitch.

Heidi Hafner,
Hafner Designs

Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
5
June 3, 2019 - 7:17 pm
sp_Permalink sp_Print

So, I was inputting the extra css code into the skin code. Changing the <h1> for the titles to be different pixel size, line-height, color, and text-align center. It did not work I went to save the template and the template didn't save. It says it's saving, but no changes were made. (Yes, I did remove the errant code before saving.) This is frustrating. This is a second website with Agility with this problem. Please advise.

Thank you

Heidi Hafner,
Hafner Designs

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
6
June 4, 2019 - 6:58 am
sp_Permalink sp_Print

Heidi Hafner said
Do the CSS edits made in the WP editor take priority over the theme CSS? My client wants me to leave it all alone except for the navbar glitch.  

Yes, they do take priority.

Heidi, give me the other site so I can see what they may have in common.

Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
7
June 5, 2019 - 2:16 pm
sp_Permalink sp_Print

The other site is https://chefeliana.com/. I have tried to make changes in both the editor and in the content & display area. I posted a separate topic post for this one in the forum.

Heidi Hafner,
Hafner Designs

Avatar
Rick Anderson
Desert Hot Springs, CA
Admin
Forum Posts: 13637
Member Since:
November 8, 2009
sp_UserOfflineSmall Offline
8
June 6, 2019 - 4:13 pm
sp_Permalink sp_Print sp_EditHistory

The 2 sites don't have the same issue as far as I can tell.

The problem with the expanding/contracting menu area comes from some conflicting CSS and then probably JS from the slider.

The conflicting CSS is 

#top_menu_area {
    background-color: #FFBF00;
    margin-bottom: -20px;
    padding-top: 0px;
}

ul {
    padding-bottom: 20px;
}
Avatar
Heidi Hafner
Sahuarita, Arizona
Member
Members

Community Member
Forum Posts: 508
Member Since:
October 7, 2012
sp_UserOfflineSmall Offline
9
June 14, 2019 - 6:13 pm
sp_Permalink sp_Print

Thanks. I'll give it go. I was told that this "friend" was battling with the slider alignment. I'll dig a little deeper.

Heidi Hafner,
Hafner Designs

Forum Timezone: America/Los_Angeles

Most Users Ever Online: 228

Currently Online:
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Keith W Jones: 1428

Brian Tozer: 1004

Carolin: 982

Heidi Hafner: 508

John Cunningham: 423

Reece Morrel: 353

Newest Members:

emma62755

sharonmarks

emma80233

Tijs de Jong

Daniel Frey

mutek

Forum Stats:

Groups: 8

Forums: 46

Topics: 6993

Posts: 34790

 

Member Stats:

Guest Posters: 6

Members: 6761

Moderators: 2

Admins: 2

Administrators: Rick Anderson, Rick Anderson

Moderators: Pierre Cote, Laura Nugent